iPhoneアプリをアップデートArchiveしようとしてBundle versionのエラーがでた


アップデートでエラーがでました。

this bundle is invalid. the key cfbundleversion in the info.plist file must contain a higher version ….

うーむversionが低いって言われてるんだけどどういうことだろうか?

症状としては以下のサイトと同じ

AppStoreのバージョン番号ではまる
http://basuke.blogspot.jp/2010/02/appstore.html

1.01みたいに設定してしまって、1.0.2とかが設定できないという症状です。

ほかのサイトにもあるけど、つまりバージョンをあげるしかない模様

App Storeに新しいバージョンをアップロードしてみる
http://d.hatena.ne.jp/itohiroki/20110116/1295160851

検索するとCFBundleShortVersionStringを変えろと書いてあるのですが、これはTARGETSにあるVersionとBuildの数字を変えればいいみたいです。Bundle versions string, shortやBundle versionも勝手に変わるはず。

1.1より上の1.1.1とかならいけるっぽい?

ということでレビュー待ちです。


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です